Ford Focus ST Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
276 Posts
Discussion Starter · #1 ·
Hi all, i started the car up and im getting a whine from what seems to be the alternator, but all the electrics are working fine and no lights have come on the dash, its seems to be getting hot aswell cant see if its turning, or seized as it sounds like the belt is just slipping ( the noise increases with engine speed).

Any idea`s cheers all.
 

·
Registered
Joined
·
1,358 Posts
Start the car up and pull out the dip stick and see if the noise stops. Could be the oil filter housing diaphragm has burst.
 

·
Registered
Joined
·
276 Posts
Discussion Starter · #5 ·
it seems to be getting hot which makes me think its stuck and the belt is slipping but ive as yet no battery drain
 

·
Registered
Joined
·
276 Posts
Discussion Starter · #6 ·
If i do need a new alternator where is the best place to use in the northwest and does anyone know how much i would expect to pay.
 
G

·
QUOTE(FST_chris @ 18 Jan 2010, 10:33 AM) <{POST_SNAPBACK}>If i do need a new alternator where is the best place to use in the northwest and does anyone know how much i would expect to pay.

Mine's just done the same - evetually battery light came on and the alternator started to seize, almost stalling the engine. Main dealer wants £481 inc to fix!
 

·
Registered
Joined
·
1,297 Posts
The alternator is about £189 and ford specify 2 hours labour to fit. Grand total should be about £305. I was quoted over £500 at one dealer and couldn't get car to to the one that quoted £305 so bought the alternator and got my local Volvo specialist to fit it, total cost was £246.

Phone round mate I wouldn't be paying that!
 
1 - 8 of 8 Posts
Top