Ford Focus ST Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
78 Posts
Discussion Starter · #1 ·
Hello,

So I got myself the recommended recirc valve at Ford Fair.
Thing is I'm so confused. I wanted an updated recirc valve and after fitting the turbo smart BOV kompact plumb part number TS-0203-1261 today it sounds so chavy. It's not a dump valve, but it hisses so loud under load it's almost embarrassing. I was informed the turbosmart kit was good. I've lost boost too, Its only hitting half way and hisses like a snake.

So is a bov a recirc?

Is the Mountune recirc valve which is advertised as a direct replacement less noisy and will I get my boost back.

P.s if anyone wants the turbosmart valve I paid 120 at ford fair for it. You can have it for half of that. I'm going on the Whitby run on 30th September. Inbox me if you want it.

Cheers in advance
 

·
Registered
Joined
·
15 Posts
I have bought the same part all be it, it was only £59.99 on Amazon back to usual £120+ now. Ive not fitted mine yet but I was under the impression that there is no difference to the sound and that it is just an updated recirc valve and not a BOV. Do you have any other mods? I have a k&n and bluefin remap.
 

·
Registered
Joined
·
78 Posts
Discussion Starter · #3 ·
That's why I'm so confused...
I've got dreamscience imap, airtec intercooler, mountune induction in the engine department.

Everything was mint prior to fitting today.

I'm gonna take it off tommorow and re fit it and see what that does..?I double checked everything today so suppose let's see Tommorow.

I was dedinatley under the impression there was no noise increase so when I heard it I knew something was not right.
 

·
Registered
Joined
·
15 Posts
I probably wont get round to swapping mine out anytime before Monday. Just need to see. Would be interested to hear from anyone else that has 1 of these with or without other mods too.
 

·
Registered
Joined
·
124 Posts
Sounds like its an issue with your valve as I am running one on mine without any issues. Mine is holding boost up to 24psi with no issues at all!
 

·
Registered
Joined
·
78 Posts
Discussion Starter · #6 ·
Panic over... removed today and noticed the two o'rings had fallen off during fitting which was allowing the flow to escape.

Refitted today with o'rings in correct position and it's mint.

There is a slight increase in turbo flutter noise, but it's better. Also got full boost back... could instantly notice as soon as I started the car after refitting.

One of the cons of doing DIY fitting.. at least the EBC yellow stuff pads went on nicely. At least I've learned something from the experience and that's how to tell when the car is poorly as it's always run mint.
 
1 - 8 of 8 Posts
Top