Ford Focus ST Forum banner
Status
Not open for further replies.
1 - 13 of 13 Posts

·
Registered
Joined
·
270 Posts
Discussion Starter · #1 ·
My engine temp seems to sit at 1/2 way regardless, but noticed on 2 runs (sat at 60mph ish in 6th) the turbo oil temp ramps up and sits on the 3/4 way round the dial mark. My St 2 never got anywhere near this.
(also when sat at this speed the turbo was on about 1/4 boost)

I have the bluefin map on my car, tbh I never took any notice before I put the map on so don't know what it was like before.

Is this normal/something to worry about?
 

·
Registered
Joined
·
6,843 Posts
Never have mine on between half and a quarter so I'd say there's something no quite right but it isn't a true reflection of how hot the oil really is as its an ecu controlled gauge rather than actually having a sender on the block, the ecu does some calculations and then the gauge reads what the ecu thinks it should
 

·
Registered
Joined
·
786 Posts
Mine sits at a quarter on gentle driving then goes up to just below half when crusing at 70 on motorway. Standard car. Does sound like something is wrong there..
 

·
Registered
Joined
·
270 Posts
Ok thanks all, if anyone notices next time there sat steady at 60ish in 6th can you let me know if the turbo boost is around a 1/4?, I would have thought it would be less to zero (no boost) (just wondering if this issue - constantly on boost?)
I have had an issue with bluefin (http://www.focusstoc...ted-by-bluefin/) could it be that?

Also noticed some of you guys are on the 225 mark2 -this one is a mark3

At the moment I have just downloaded the correct map for my orginal settings, gonna put that back on and see if any difference?
 

·
Registered
Joined
·
12,607 Posts
Ok thanks all, if anyone notices next time there sat steady at 60ish in 6th can you let me know if the turbo boost is around a 1/4?, I would have thought it would be less to zero (no boost) (just wondering if this issue - constantly on boost?)
I have had an issue with bluefin (http://www.focusstoc...ted-by-bluefin/) could it be that?

At the moment I have just downloaded the correct map for my orginal settings, gonna put that back on and see if any difference?
Completely depends on the throttle position. I can drive with the gauge saying 1/4, or 0 depending on the position. I wouldn't read into it too much anyway. Fishy's seen his gauge reading 1/4 while his real gauge still read a vacuum...
 

·
Registered
Joined
·
6,843 Posts
Sorry can't really comment on a MK3 as its a totally different engine and I would think because its a 2 liter it may still be showing boost when a 2.5 liter wouldn't due to the smaller capacity

Like I said I wouldn't read too much into what the gauges say as they are not accurate enough as its all controlled by the ECU not the normal sender units for each gauge like it should really be.

If your worried take it back to ford and ask them to check it out as cooking the oil wont be doing the engine much good but this may settle down once the engine has done a few thousand miles
 

·
Registered
Joined
·
270 Posts
Discussion Starter · #12 ·

·
Administrator
Mk2 RS MP350
Joined
·
24,591 Posts
As requested.
I've also updated your profile to indicate you own an ST250.
 
1 - 13 of 13 Posts
Status
Not open for further replies.
Top