Ford Focus ST Forum banner
1 - 15 of 15 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
can anyone help me?
my turbo only seems to want to work now and then, has now gone completely
any ideas???
also, on start up, i have an orange engine management light come up, no other lights, gages, or windows work, until around 8 seconds when it all kicks in, any ideas on that one please?
have a feeling ill be spending some money this christmas.

al
 

·
Registered
Joined
·
7,012 Posts
When you say your turbo isn't working, are you getting any boost at all?
A common issue with loosing boost can be the boost solenoid, which is a quite simple fix if it is that part.
 

·
Registered
Joined
·
204 Posts
Alternator/Battery for your windows (and associated) issues. Alternators go around this time of year with cold etc, so possible.

Boost Solenoid for your boost issue (£40/£50 fix).

Best of luck.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #4 ·
every now and then, on accelaration the turbo would hit around half way or red, but over last week, its been very intermittent, and doesn't always work on accelaration, leaving me with no boost at all, now seems to have packed up altogether? and now feels very sluggish, horrible to drive. (thanks for reply)
 

·
Gok Wan
Joined
·
2,642 Posts
Put a volt meater on your battery with the car on put your light on heater on full and the volt should be 14 if its 12 or 11 then your battery or alternators has gone
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #8 ·
thanks for your reply, ill definitely try that one, do you think its possible it would last all this time? the same fault i mean, if its the battery or alternator? cheers
 

·
Registered
Joined
·
105 Posts
Think I'm getting kinda the same thing but no working lights. Just taken the car out and when I accelerate the boost won't even reach half way. Just had the car put to stage 3. Was fine all weekend.
Just tried adding a video- not sure it's worked..
 

·
Registered
Joined
·
5,303 Posts
Random boost pressure is a common sign of the boost solenoid dying.

Alex, if you have the engine light on you really need to get the fault codes checked and cleared, that will point you to what the problem is. Whereabouts are you? Do you have a code reader?
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #13 ·
Random boost pressure is a common sign of the boost solenoid dying.

Alex, if you have the engine light on you really need to get the fault codes checked and cleared, that will point you to what the problem is. Whereabouts are you? Do you have a code reader?
hey, if the boost solenoid is faulty, would it put the engine management light on?
on start up, the engine management light comes on, as does the red arrow, but the rest ..... windows/radio/ gauges, or any other lights dont work for a good 8-10 seconds, then the light and arrow disappear, and then the rest fires up,
have had it put on a non ford machine and nothing shows up, i dont have a code reader, our local ford garage haven't been much help, i.e "could be anything" dont really wanna book it in and be ripped off like main dealers do,
im in basingstoke, hampshire
appreciate any advice and help
 
1 - 15 of 15 Posts
Top