Ford Focus ST Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
124 Posts
Discussion Starter · #1 ·
Hello all

Ever since i had the new engine fitted the throttle response seems to be terrible in comparison to the old engine, especially at low revs in high gears. I was wondering, should it vary that much from car to car and is there anything that i can do about it?

Cheers
Dazza
 

·
Registered
Joined
·
13,907 Posts
QUOTE(Dazza123 @ 6 Dec 2009, 10:09 PM) <{POST_SNAPBACK}>Hello all

Ever since i had the new engine fitted the throttle response seems to be terrible in comparison to the old engine, especially at low revs in high gears. I was wondering, should it vary that much from car to car and is there anything that i can do about it?

Cheers
Dazza

The best thing to do would be to take it back to the dealer and see if they can update the software on your ecu.
Are there any other symptoms?
 

·
Registered
Joined
·
124 Posts
Discussion Starter · #3 ·
Nope, just went for a late night blast and everything else is absolutely pucker and once its warm it doesn't do it after 3000 rpm and it's only when i put my foot down as fast as possible. But it definitely 100% wasn't doing it before, not like that. But no, other than that she's in perfect working order.
 

·
Registered
Joined
·
244 Posts
QUOTE(Dazza123 @ 7 Dec 2009, 12:35 AM) <{POST_SNAPBACK}>Nope, just went for a late night blast and everything else is absolutely pucker and once its warm it doesn't do it after 3000 rpm and it's only when i put my foot down as fast as possible. But it definitely 100% wasn't doing it before, not like that. But no, other than that she's in perfect working order.
Did you just say "pucker"?


Are you running the standard map?

Mine used to be terrible running Mod B.
 

·
Registered
Joined
·
124 Posts
Discussion Starter · #5 ·
QUOTE(admire that @ 7 Dec 2009, 01:14 AM) <{POST_SNAPBACK}>Did you just say "pucker"?


Are you running the standard map?

Mine used to be terrible running Mod B.
Haha, i did say pucker which i don't think i have ever done before. . .interesting!! I'm running Mountune but i was on the old engine as well and like i said it was ok then (although never what i called perfect). But in fairness it doesn't affect the performance because it's rare you accelerate hard without dropping a cog, thus using the clutch, thus throttle response isn't really an issue. I can get around it. I'm going to get the Mountune wheels fitted soon so i'll have a word with EMG when i get there and see if they can do anything about it. Might have the sports cat and down pipe fitted, hoping that will add to the pops and bangs from the cat back even more, plus adding more power!!
 

·
Registered
Joined
·
244 Posts
QUOTE(Dazza123 @ 7 Dec 2009, 12:25 PM) <{POST_SNAPBACK}>Haha, i did say pucker which i don't think i have ever done before. . .interesting!! I'm running Mountune but i was on the old engine as well and like i said it was ok then (although never what i called perfect). But in fairness it doesn't affect the performance because it's rare you accelerate hard without dropping a cog, thus using the clutch, thus throttle response isn't really an issue. I can get around it. I'm going to get the Mountune wheels fitted soon so i'll have a word with EMG when i get there and see if they can do anything about it. Might have the sports cat and down pipe fitted, hoping that will add to the pops and bangs from the cat back even more, plus adding more power!!
If there is noticable lag and there wasn't before, I'd certainly get it looked at.

You shouldn't have to "get around" the issue. Your car should just be right!
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top