Ford Focus ST Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hi people.. need some help please..
I have a focus ST225 mk2, 2008. its done 110,000,

Recently I gave my car a standard service, the norm ie oil/filter , oil, and new plugs , nothing major simple stuff that i have been doing ever since i turned a wheel. The problem I have noticed is the car surges when I let off the throttle after doing a big pull in anything higher than 2nd gear.. By this I mean litterally that! I first noticed it when I wanted to show how well the car pulled to a friend of mine. I allowed a big gap infront to build, selected 3rd, stuck my foot down to the floor, when the car had got to almost as far as i dare take it ( not red line ) I let the throttle off and as I do its almost as if I have re-applied the full throttle for a seconed or so. Happens like I said before, anything highter than 2nd.. Any idea's??

I have rechecked the joins on the crossover pipe and the down pipe to the turbo and they are all good. Ive even changed the spark plugs to the same that go in the RS so they are irridiums and gapped them aswell.. Trouble i have is that the car may well of had this issue before the service as it was a while before I gave it a good thrash ( so to speak ) just seems to be almost as if its down on power and not pulling as hard as when i first got it. the reason i say this is probably due to the so called " surge " of power once off the the throttle.. The car has a stage one revo map and is ( so said according to paper work ) making 275bhp. There has been a Airtech airfilter fitted aswell.

Any help would go miles..
Many thanks
 

·
Premium Member
MK3
Joined
·
87 Posts
Sounds potentially like there could be a problem with the BOV / Recirculation Valve. It may not be up to the job, have a fatigued spring / the incorrect spring weight, sticking mechanism.
 

·
Premium Member
Joined
·
1,207 Posts
I think it’s more likely to be the throttle butterfly sticking open. Fly by wire throttle bodies are often difficult to clean and if it is actually the problem it might need to be replaced but if you can check the butterfly for gunk it’s worth trying to clean it up first.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #6 ·
Just to let people know what it the problem turned out to be on the surging..

I took my car to SCC Performance in St Albans. They test drove and experienced the so called surging under load.. plugged the car in and found a load of codes . Turned out that when the engine was under load and moving on the mounts the loom wires from the ecu and map sensor had been rubbing on a bracket where it bends round just past the gearbox. Evidently the bolt on this bracket had rubbed through some of the insulation on the loom. Repaired and fixed.. car is now back to normal.. the good thing is it only cost me £80. ! Tha ks for your input guys, I'm going to replace the recet valve anyway.
 
1 - 6 of 6 Posts
Top