Ford Focus ST Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1,355 Posts
Discussion Starter · #1 ·
Went to get the car out of the garage this morining and the battery was that flat it wouldnt even open the doors, Put the key in the ignition and not so much as a light on the dash
- Got it started with the "ol" jump leads and left to run for 10 mins before trying to pull it out of the garage. When i jumped in there was a msg on the display saying something like "major ecu error", When i depressed the accelerator pedal nothing happened, it just remaind on tickover. Turned off and then back on and got a new message of "restricted acceleration" but it would now rev ok.

Took it to my mates garage and he cleared all of the fault codes for me without issue
, Took it for a good blast out and all is now well.

Remember reading a thread a while ago about the ecu having to re learning your driving style after disconnecting the battery, Does anyone know why (if it actually does) it does this and if there are any advantages?
 

·
FocusSTOC Nut!
Joined
·
17,448 Posts
the kam will learn your throttle inputs etc mate. drive the nuts off it for a while and it will feel much more responsive.
 

·
Registered
Joined
·
1,355 Posts
Discussion Starter · #3 ·
the kam will learn your throttle inputs etc mate. drive the nuts off it for a while and it will feel much more responsive.
Thats exactly what i did today Stingy, Seemed a little hessative after the codes had been cleared but was still boosting over 1.2 bar as normal. An hour and a half, quater of a tank and some fantastic country roads and it felt sharp as a pin again
 
1 - 3 of 3 Posts
Top