Ford Focus ST Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
270 Posts
Discussion Starter · #1 ·
Hi all ,
just tried to change my car back to stock with DS and while downloading it just turned off and now car wont start and ds will not work.

any ideas
 

·
Super Moderator
MK3 Focus RS Nitrous Blue
Joined
·
8,488 Posts
It may be a fuse have a look in the technical section for which fuse,just done mine don't need the extra power or torque better to be safe
 

·
Banned
Joined
·
6,700 Posts
Try searching for info on the OBD fuse - this can blow sometimes and then you either get an error on the DS unit or no power at the port to power up the handset. Wild guess says fuse 15? reckon it will be one of the ones behind the glovebox rather than in the engine bay but I may be wrong.

EDIT think Orangeman's got the info for you
 

·
Banned
Joined
·
6,700 Posts
QUOTE(Goodyear @ 3 Jan 2010, 04:44 PM) <{POST_SNAPBACK}>found the blown fuse and there is no spares and the local garage only has 25amp . this day is getting worst by the min!
Find another fuse in the fusebox the same size, that covers something not important and swap that one for now to get the car up and running. Also check in case there's any spares in the fusebox in the engine bay. Probably not but worth a look.
 

·
Super Moderator
MK3 Focus RS Nitrous Blue
Joined
·
8,488 Posts
Glad you got it sorted not sure what causes the fuse to blow i think it just happens,get a couple of spares to be on the safe side
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top