Ford Focus ST Forum banner
1 - 18 of 18 Posts

·
Registered
Joined
·
128 Posts
Discussion Starter · #1 ·
Hi, just bought a 2006 EO ST3 a few weeks ago which im in love with. Already put side stripes and bluefin remap too. But was wondering if i have a boost problem. I cant get the boost reading much past the quarter mark even when thrashing it and thought with the bluefin remap i should be getting more? Do i have a boost leak? And if so how do i tell and whats the cure?
Thanks in advance for any advice
Dodi
 

·
Registered
Joined
·
293 Posts
sounds to me its in safe mode for some reason you can clear this by removing the KAM fuse have a search lol if not then a few people have had the CAT collapse and this causes only small amount of boost also if your hands on have a look if not get it booked in, like said if your running a remap you should be boosting near to the red on the boost gauge
 

·
Registered
Joined
·
128 Posts
Discussion Starter · #5 ·
thanks for the quick replies. Ive got a stage one bluefin fitted at he mo. Going to try the KAM fuse 26 reset and see if that makes any difference, do u reckon failing that i should put it back to standard to reinstall the bluefin?
 

·
Registered
Joined
·
128 Posts
Discussion Starter · #6 ·
thanks for the quick replies. Ive got a stage one bluefin fitted at he mo. Going to try the KAM fuse 26 reset and see if that makes any difference, do u reckon failing that i should put it back to standard to reinstall the bluefin?
 

·
Registered
Joined
·
128 Posts
Discussion Starter · #8 ·
QUOTE(loko @ 18 Jan 2010, 08:40 PM) <{POST_SNAPBACK}>certainly no harm in trying
Just tried resetting the KAM, made a little difference, a bit sharper but not much more boost. Reinstalled Bluefin and made no difference to boost but more torque, might have to get it booked in I reckon
 

·
Registered
Joined
·
128 Posts
Discussion Starter · #9 ·
Had it on the rolling road and was only showing 180 horsepower (with Bluefin) and was reading an overboost. The guy reckons its the MAP sensor telling the actuator that its got too much boost and then dumping it when in fact its got no where near as much boost as it should. Disconnected the MAF sensor and it dropped power again so ruled that out. Ruled out the Cat collapsing because of the "overboost" reading.
Took it back to Ford and explained the problem to the receptionist which they completely ignored and simply did a software update and claimed it was sorted. Unfortunately its made no difference at all so took it back immedietely. Got the master mechanic out , explained to him and showed my dyno readings to which he finally admitted it was down on power and boost and has ordered a new Map sensor which is getting fitted tomorrow...fingers crossed that it works.
Failing that any ideas what else it could be?
Might as well have my ST170 back at this rate lol
 

·
Registered
Joined
·
5,303 Posts
Where in Yorks are you mate? Just wondering if its worth you taking it to Pioneer tuning in Hull as they are a superchips dealer... Maybe they could sort it out for you quicker than fraud?? Being a 2006, Fraud will be wanting to charge you handsomely for any work they do... Alternatively, pop it over to Gary at profile, he will have it running right in a jiffy im sure... or dreamscience in Hull might be able to help out, even though you have gone with Bluefin instead of DS lol

Mark

EDIT - When you say it was reading an overboost, did this show as a fault code or the actual measured boost pressure was high?
 

·
Registered
Joined
·
128 Posts
Discussion Starter · #11 ·
QUOTE(mbaker @ 4 Feb 2010, 03:33 PM) <{POST_SNAPBACK}>Where in Yorks are you mate? Just wondering if its worth you taking it to Pioneer tuning in Hull as they are a superchips dealer... Maybe they could sort it out for you quicker than fraud?? Being a 2006, Fraud will be wanting to charge you handsomely for any work they do... Alternatively, pop it over to Gary at profile, he will have it running right in a jiffy im sure... or dreamscience in Hull might be able to help out, even though you have gone with Bluefin instead of DS lol

Mark

EDIT - When you say it was reading an overboost, did this show as a fault code or the actual measured boost pressure was high?

it showed as overboost fault code and the dyno registered a high boost reading even though the gauge wasnt showing anywhere near. The gauge was still on quarter. Its still under the 3 months warranty i got with the car so going to let ford fit the map sensor first but failing that i might just give him a call.
Cheers
 

·
Registered
Joined
·
5,303 Posts
OK... If it is showing as overboost on the fault code and also on the dyno then I suspect your gauge is knackered.... Where they actually measuring boost pressure directly on the dyno?
If it is overboosting, it could still be a broken up cat. It gives overboost by restricting the gas out of the exhaust. That means teh gases "back up" through the engine and give a high back pressure at the inlet valves, which ends up giving you a high boost pressure at teh outlet of the turbo. Due to the blockage though, the high boost pressure cant actually push air through into the cylinders so gives you a fault and reduced performance... Could also be the MAP sensor though...

See how you get on at Ford, where are you located?

Mark
 

·
Registered
Joined
·
128 Posts
Discussion Starter · #13 ·
QUOTE(mbaker @ 4 Feb 2010, 04:35 PM) <{POST_SNAPBACK}>OK... If it is showing as overboost on the fault code and also on the dyno then I suspect your gauge is knackered.... Where they actually measuring boost pressure directly on the dyno?If it is overboosting, it could still be a broken up cat. It gives overboost by restricting the gas out of the exhaust. That means teh gases "back up" through the engine and give a high back pressure at the inlet valves, which ends up giving you a high boost pressure at teh outlet of the turbo. Due to the blockage though, the high boost pressure cant actually push air through into the cylinders so gives you a fault and reduced performance... Could also be the MAP sensor though...See how you get on at Ford, where are you located?MarkCheers Mark ill let you know how i get on tomorrow. They agreed to fit the map sensor while i wait. If no luck ill request them to have a look at the cat while im there. My warranty excludes exhaust system but its been doing it since i got the car. Im located near Darlington. Fingers crossed for tomorrow. Just want it sorted so i can get on and enjoy the extra power!!sorry forgot to add they were measuring boost on the dyno
 

·
Registered
Joined
·
1,355 Posts
QUOTE(dodi @ 4 Feb 2010, 07:21 PM) <{POST_SNAPBACK}>. My warranty excludes exhaust system but its been doing it since i got the car. Im located near Darlington.

Most warranty's exclude exhausts but if the cat is inefficient they should pay up, I had mine done under the autocare warranty, Dont let them fob you off mate


Which ford dealer are you taking it too, Not the one in Aycliffe is it?
 

·
Registered
Joined
·
128 Posts
Discussion Starter · #15 ·
QUOTE(christiano @ 4 Feb 2010, 07:37 PM) <{POST_SNAPBACK}>Most warranty's exclude exhausts but if the cat is inefficient they should pay up, I had mine done under the autocare warranty, Dont let them fob you off mate


Which ford dealer are you taking it too, Not the one in Aycliffe is it?

no mate the one in Darlington...did yours have similar symptoms when the cat was
?
cheers
 

·
Registered
Joined
·
1,355 Posts
QUOTE(dodi @ 4 Feb 2010, 07:42 PM) <{POST_SNAPBACK}>no mate the one in Darlington...did yours have similar symptoms when the cat was
?
cheers

Where is the Dealer at in Darlo mate, I work in Darlo and it would be handy for parts as the dealer in Aycliffe has the worst customer service i have ever come across


Mine Ran fine to be honest, It was only at it's first test that the emissions were sky high so had it replaced.
 

·
Registered
Joined
·
128 Posts
Discussion Starter · #17 ·
QUOTE(christiano @ 4 Feb 2010, 07:58 PM) <{POST_SNAPBACK}>Where is the Dealer at in Darlo mate, I work in Darlo and it would be handy for parts as the dealer in Aycliffe has the worst customer service i have ever come across


Mine Ran fine to be honest, It was only at it's first test that the emissions were sky high so had it replaced.

Its just off the A1 mate. Take the A66 off the A1 and head towards Darlo. Think its the second roundabout its on, Evans Halshaw Ford
 

·
Registered
Joined
·
128 Posts
Discussion Starter · #18 ·
QUOTE(dodi @ 4 Feb 2010, 08:05 PM) <{POST_SNAPBACK}>Its just off the A1 mate. Take the A66 off the A1 and head towards Darlo. Think its the second roundabout its on, Evans Halshaw Ford

Just an update to my prolonged boost problem. Ford changed the map sensor and it made
all difference
. Took it back in very unhappy and explained nicely to the receptionist that i am not taking the car back until this problem is fixed. 4 days later i got a phonecall from them to explain that it was going to need a new turbo! (Warranty job). And they would need authorisation first b4 they could carry out the work but said it should take no more than 5 days to do.
Rang back 5 days later only to find they had just got the authority that day!!! Best of all they hadnt even ordered the new turbo!! Even better than that it had to be ordered from Germany!!
Now over 2 weeks later since i took it back and still driving round in this embarasing Fiesta courtesy car (i keep getting checked out by lads expecting a girl to be driving!!)
Really starting to regret buying this car now, as im doubting after ford clutching at straws b4 that fitting this new turbo makes any difference to the problem.
Ill keep yous updated peeps
 
1 - 18 of 18 Posts
Top