Ford Focus ST Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
629 Posts
Discussion Starter · #1 ·
I fitted an elevate RARB 2 weeks ago and yesterday I heard a clunking/ knocking noise coming from the rear of my ST. I've had a look under the car and where the drop links are bolted to the RARB was loose. It's caused be the powder coating wearing away under the nut.

All you need is a 5mm Allen key and a 15mm spanner. Leave the car on the ground and crawl under to tighten it up at both ends.

I'm gonna check it again in a couple of days to see if it needs more tightening and ill post it up in here if it does.
 

·
Registered
Joined
·
24,177 Posts
I fitted an elevate RARB 2 weeks ago and yesterday I heard a clunking/ knocking noise coming from the rear of my ST. I've had a look under the car and where the drop links are bolted to the RARB was loose. It's caused be the powder coating wearing away under the nut.

All you need is a 5mm Allen key and a 15mm spanner. Leave the car on the ground and crawl under to tighten it up at both ends.

I'm gonna check it again in a couple of days to see if it needs more tightening and ill post it up in here if it does.
Its not caused by the powdercoating wearing away as that part does not move unless the droplinks are seized!
 

·
Registered
Joined
·
7,372 Posts
One of mine came loose purely because I hadn't tightened it enough.
It's hard to gauge just how tight they need to be. Especially when you've got just a 5mm Allen key to hold onto.

I've got some new drop links on order. They aren't that expensive.
 

·
Registered
Joined
·
629 Posts
Discussion Starter · #4 ·
Its not caused by the powdercoating wearing away as that part does not move unless the droplinks are seized!
I fitted brand new drop links when i put the RARB on so they cant be siezed can they? I could see where the powder coating had been worn away. I only got about half a turn on them to tighten it up.
 

·
Registered
Joined
·
7,372 Posts
The powder coat probably came off when you tightened them up.

Fishy is bang on. The drop link shound not be spinning within the rarb
 

·
Registered
Joined
·
629 Posts
Discussion Starter · #6 ·
The powder coat probably came off when you tightened them up.

Fishy is bang on. The drop link shound not be spinning within the rarb
If the coating had came off when I first put it on it would have been knocking from the minute I drove the car. It has gradually worn away over the 200 miles or so I've done.

I did not say the drop link was spinning in the RARB and neither did fishy. it has been done by the up/ down movement or pressure when the car is cornering.
 

·
Registered
Joined
·
7,372 Posts
If the coating had came off when I first put it on it would have been knocking from the minute I drove the car. It has gradually worn away over the 200 miles or so I've done.

I did not say the drop link was spinning in the RARB and neither did fishy. it has been done by the up/ down movement or pressure when the car is cornering.
i know you didn't. Fishy was stating a possible reason why you are encountering the noise you have.

from your above comment it must mean that you didn't tighten them up enough.

Ps. i'm only trying to help. I had the same problem on mine.
 

·
Registered
Joined
·
24,177 Posts
As Nathan says the only possible cause was the droplinks not being done up tight enough to start with assuming the new droplinks are free moving!
 

·
Registered
Joined
·
622 Posts
I had mine fitted today the elevate RARB fitted along with spacers and my decat. Drove away all done then there was a clunk, pulled over and thought it was the original roll bar and decat banging in the back problem solved on my journey back nothing wrong RARB not faults.

Until know got to my mums then when i left the house 2 miles in get a knocking noise when rolling down hill, so I pop to Kwit fit and they checked the spacers as the noise was coming from the front, loose bolts all sorted. Then as I slow pull away a massive clunk felt sick when I heard it,

I nursed the car home as kwit was just shuting and it sounds horrible loud clunking noise coming from under Neath the car all the time.
Back in to kwit to check this out. I hope it's the RARB and can be swiftly sorted not looking for to getting back in the car though.

Glad someone started this thread misses is going mental coz of this (stupid mods as she says)

This happened all today
 

·
Registered
Joined
·
24,177 Posts
I had mine fitted today the elevate RARB fitted along with spacers and my decat. Drove away all done then there was a clunk, pulled over and thought it was the original roll bar and decat banging in the back problem solved on my journey back nothing wrong RARB not faults.

Until know got to my mums then when i left the house 2 miles in get a knocking noise when rolling down hill, so I pop to Kwit fit and they checked the spacers as the noise was coming from the front, loose bolts all sorted. Then as I slow pull away a massive clunk felt sick when I heard it,

I nursed the car home as kwit was just shuting and it sounds horrible loud clunking noise coming from under Neath the car all the time.
Back in to kwit to check this out. I hope it's the RARB and can be swiftly sorted not looking for to getting back in the car though.

Glad someone started this thread misses is going mental coz of this (stupid mods as she says)

This happened all today
Who fitted them?
 

·
Registered
Joined
·
444 Posts
I had mine fitted today the elevate RARB fitted along with spacers and my decat. Drove away all done then there was a clunk, pulled over and thought it was the original roll bar and decat banging in the back problem solved on my journey back nothing wrong RARB not faults.

Until know got to my mums then when i left the house 2 miles in get a knocking noise when rolling down hill, so I pop to Kwit fit and they checked the spacers as the noise was coming from the front, loose bolts all sorted. Then as I slow pull away a massive clunk felt sick when I heard it,

I nursed the car home as kwit was just shuting and it sounds horrible loud clunking noise coming from under Neath the car all the time.
Back in to kwit to check this out. I hope it's the RARB and can be swiftly sorted not looking for to getting back in the car though.

Glad someone started this thread misses is going mental coz of this (stupid mods as she says)

This happened all today
what was this in the end? sorry for the thread revival
 

·
Registered
Joined
·
622 Posts
Clunked all the way to kwit fit. Took out the guy from kwit down the worst road close by to try and isolate the noise. And it was diffently the rear of the car. Anyway all we did was tighten the bolts and gave it a test drive and if by magic it worked.
 
1 - 13 of 13 Posts
Top