Ford Focus ST Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
271 Posts
Discussion Starter · #1 ·
As title getting a hesitation at 3000rpm does not happen every time but would like your thoughts? You can feel the car hold back then it just goes again not every time. Cheers
 

·
Registered
Joined
·
732 Posts
Had the same problem myself a few weeks ago, these guys told me to try plugs, replaced them and now all is smooth and happy
 

·
Registered
Joined
·
271 Posts
Discussion Starter · #6 ·
only had a set of plugs 1000 mile ago plus full service. Mods K&N Panel filter. Pro alloy front mount. DSCI Map. Decat.
 

·
Registered
Joined
·
7,012 Posts
I had this when I got the ultimate 412 map installed from Pumaspeed, turned out my plugs were knackered.
I got a set of RS plugs and not had an issue since, smooth as a baby's bottom.
 

·
Registered
Joined
·
570 Posts
I get this sometimes but I've got a K&N 57i cais whereas you have a panel filter so that won't be it. As Ade_cx said check if its not the ESP (traction control) throwing a wobbler. Sometimes on a wet road even in 4th it'll kick in for me and gives this hesitation feeling around 3000rpm when the car hits full boost/power. It'll flicker on the dash as a yellow car with tyre marks following it.

Or as others have said could be the plugs. Was it doing this before you changed your plugs or has it just started recently?
 

·
Registered
Joined
·
271 Posts
Discussion Starter · #11 ·
Thanks for the replys guys. Seems to be only doing it when the traction controll is on. When i turn it off it seems to be dead on and just pulls every gear. So will keep an eye on it.
 
1 - 11 of 11 Posts
Top