Ford Focus ST Forum banner
1 - 20 of 37 Posts

·
Registered
Joined
·
222 Posts
Discussion Starter · #1 ·
Please help guys i have a big problem. Tonight i ran my ST throught town with the ESP on and after i while i stopped at a gas station. After i payed i got in the car and when i put the ignition on i got ESP SYSTEM FAUL Error. I cannot engage the ESP and it is no running. I tried restrating the engine but i get the same error. The error is shown even with the engino off but with the ignition on.

Please help.

(
 

·
Registered
Joined
·
1,918 Posts
Unfortunately this can be many things mate !!

Do you have a scan guage or DS map handset ??

Check for DTC's and clear them after noting what they are. Also when i had it come on my car i reloaded the map and it cured the fault. Some others are not so straight forward.
 

·
Registered
Joined
·
222 Posts
Discussion Starter · #3 ·
I do not have a ds hand held because i have superchips. Tomorow i will try to disconect the battery to see if it goes away. I hope it is not the Abs module.
 

·
Registered
Joined
·
1,918 Posts
Havent you just fitted a new induction kit ????


Try cleaning the MAF sensor mate just incase your filter has oiled the sensor alittle. !!

worth a try !
 

·
Registered
Joined
·
2,402 Posts
try pulling the cam fuse out for 30 mins that may well clear the fault .
check for boost leaks at all joints aswell especialy the one that connects to the back of the left hand side of the engine as this is quite well known for this kind of error.
also might pay to check the maf conection as with some aftermarket cais the battery tray can catch the plug and pull out ,again giveing this kind of msg.
i think when my abs unit went i had ESP SYTEM FAIL come up and not ESP SYTEM FAULT .
hope this helps and you get it sorted out as can be a real pain to
find solve this kind of problem .
edit ...just seen in previous post that youv recently fitted and induction kit ?defo check for leaks and clean the maff ,when i fitted a K&N gen 2 cais "which i no longer have as got dreamscience one now"i had the same issue ,turns out the filter was over oiled which lead to fouling the maff,so had to clean the filter aswell .
 

·
FocusSTOC Nut!
Joined
·
17,448 Posts
take out the kam fuse mate, number 26 under the bonnet. leave it out for 30mins.
this will clear the fault. could be any number of things. it might never come back.
happened on mine the other night. just done as above myself & its not came back since.

^beat me to it^ odds on its the maf sensor mate. if it comes back clean it with some contact cleaner!
 

·
Registered
Joined
·
222 Posts
I will try to pull put the cam fuse but i do not know where the fuse box is. And are you sure is number 26? Because my car is left hand drive for Europe not UK. If this dosent work i will try cleaning the MAF sensor with alcool.

Hope is not sometrhing broken
.

LE: I forgot to ask you if i need to disconect the battery before i pull out the fuse. And when you had the problem with the error did you ESP work, because mine doesnt.

LE2: I found the Kam fuse but do i need to remove the battery?

LE3: Just pulled out the kam fuse. I am going to let it off for at least 30 mn and i will try to see if the ESP FAULT Error is gone. Keep your fingers crossed.
 

·
FocusSTOC Nut!
Joined
·
17,448 Posts
QUOTE(darian @ 21 Feb 2010, 08:49 AM) <{POST_SNAPBACK}>It worked. I hope i will not get the error soon. Thanks alot guys.


thats great mate. its probably oil on the maf from your itg filter. if it comes back clean the maf and filter.
 

·
Registered
Joined
·
2,402 Posts
nice one ,when i had this msg up the actuall ESP switch made no differance ie it didnt change the error msg nor did it light up the ESP off light on the dash .
 

·
Registered
Joined
·
222 Posts
Discussion Starter · #12 ·
When i had the error the ESP didnt work but know it does after reseting the KAM.

Does anyone know if the abs module could still be the problem? I hope the error will not come back.
 

·
Registered
Joined
·
2,402 Posts
i doubt it will be the ABS module as when they go you cant get rid of the msg at all ,or at least in most cases you cant .
more than likely your filter has oiled up the maf so if this should happen again id take it off and clean the maf,filter and pull kam fuse again then take it from there .
 

·
FocusSTOC Nut&#33;
Joined
·
17,448 Posts
QUOTE(darian @ 21 Feb 2010, 05:46 PM) <{POST_SNAPBACK}>Me2. I noticed that the ST goes like crazy know. I big improvment in throttle response
drive it like you stole it for a while mate & it will memorise your driving style & stay more responsive.
 

·
Registered
Joined
·
222 Posts
Discussion Starter · #18 ·
If i can because the trafic i awfull. I will reset the Kam again after i make the updates: exhaust, intercooler.
 

·
Registered
Joined
·
118 Posts
hi, guys i have the same problem and have booked my car into get looked at, but this could be a blessing finding this post, i am going to clean my maf and take the cam fuse out, but when i take the fuse does the car need to be running? how does it reset then if not?
 

·
FocusSTOC Nut&#33;
Joined
·
17,448 Posts
QUOTE(GERARDPPM @ 22 Feb 2010, 11:33 PM) <{POST_SNAPBACK}>hi, guys i have the same problem and have booked my car into get looked at, but this could be a blessing finding this post, i am going to clean my maf and take the cam fuse out, but when i take the fuse does the car need to be running? how does it reset then if not?
hi mate. no, don't have the car running. just take out fuse no26 for 30 mins and it will clear the fault.
by removing the fuse you will break the circut and the kam will lose any stored memory.
it will then start to learn your driving style over the next 300 miles or so.
this can be very beneficial if you bought the car second hand as it will have stored the previous owners driving style.
if the fault is serious it will come back. if its just a blip it won't.
under the fuse box lid you will find a red fuse puller to help get it out.
just take out the fuse, have a cup of tea and hopefully it will sort your problem mate.
let us know if it works for you.
 
1 - 20 of 37 Posts
Top