Ford Focus ST Forum banner
1 - 4 of 4 Posts

Registered
Joined
2 Posts
Discussion Starter · #1 ·
Please help!!!

Hi I have a issue with my st225 2010 Gearbox.

I have recently changed the engine the old one was knackered bottom end knock and all sorts, so I changed the engine and everything went as planned.

Now though the car has a gearbox issue where when the car is driving It will not let me select 5th and 6th at all, its like there locked. But I if I stop with the engine running I can select every gear no problem.

I have the traction control light on the dashboard and that's it I have code read the car but nothing shows up.

Please please send help 馃檹

Thank you in advance if anyone can help
 

Registered
Mk2 RS 400
Joined
5,171 Posts
Do you have any ABS warning lights and is the mileage showing on the dash?

If the ABS leads are disconnected you won鈥檛 be able to select 5th and 6th.

To fit the engine you could have disturbed them.
 

Registered
CP320
Joined
1,949 Posts
As K3FUS said, it's probably an ABS fault. Check all the wheel speed sensors are plugged in properly as an easy starter.

Did you remove or replace the module at all during the engine swap? Also check the loom multiplug to the module is properly secured and plugged in.
 

Registered
Joined
2 Posts
Discussion Starter · #4 ·
All I did guys was swap engine, which I'm more then happy with it purrs like a kitten so over moon with that, I did nothink with the yew sensor as it was workin fine before that didn't disconnect ecu just unplugged all connections around the engine. Had to replace speed sensor in top gearbox but that's it everything else is plugged in as shud be,

I have been told that having esp (traction control) light on dash would lock 5th n 6th? Is there any truth to that and if so how do I fix cuz I'm ****ed now basically lads out of ideas, curl up into a ball and cry like baby lol

Thanks again
 
1 - 4 of 4 Posts
Top