Ford Focus ST Forum banner
1 - 15 of 15 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter · #1 ·
Hi i have fitted this pumaspeed forge actuator (yellow Spring) & it holds the boost lovely in the midrange & doesn't drop off.

After i fitted it i have encountered some problems,, The car boosts up hard & holds boost alot better than before but as it gets to 5000rpm the boost gauge just drops to zero & it loses all power!!!

Kind of goes into limp mode.. I set the preload on the actuator & it's only boosting to 1.2bar as before. MMMM

So i fitted a Greddy ProfecB spec II boost controller to try & overcome this problem,, Back on the Dyno to set to boost..
All was going ok, Boost controller OFF, 0.7 bar 270bhp & revs right through to 6000rpm.
LOW boost 0.9 bar 286bhp & revs to 5200rpm then cuts!!
HIGH boost 1.1 bar 290bhp & cuts at 4700rpm!!!

Took off the DS & uploaded a BF stage 3+ thinking it was the map & the ecu not liking the boost!!!
Still no joy.. Took off the boost controller & the Actuator & put on the stock one..

Still have the same problem.. Took of the map so running stock 0.7 bar & doesn't cut the revs


Spent sometime on the phone to a few companys & had no feedback about this problem...
Please let me know if someone has had this problem cause it's driving me insane & getting to stage of putting the car back to stock & seeling it..
 

·
Registered
Joined
·
42 Posts
Discussion Starter · #3 ·
QUOTE(Jimothy @ 8 Dec 2009, 10:02 AM) <{POST_SNAPBACK}>Have you checked the intake pipe to the turbo isn't collapsing?
Thanks for the input will try it thanks.. Back on the dyno again!!
 

·
Vendor
Joined
·
2,676 Posts
Have you asked Pumaspeed for advice - I am sure that Tony can sort it out for you?

It could be another sensor starting to fail such as the MAF or the MAP - or even the Turbo solenoid valve?

We have not messed around with cars with uprated actuators yet - however we have sorted a few where the standard ones where messing around.

You give me a call any time if you whant any help
 

·
Banned
Joined
·
6,700 Posts
It's not suffering from a severe overboost and going into limp mode is it?

People in the know tell me you can't rely on the dash mounted boost gauge, especially if it's boosting higher than 1.2 bar but the needle can't actually move any further?

Would the car need remapping to suit the uprated actuator? if it's telling the actuator to reduce boost but the actuator isn't behaving as expected (i.e. like the standard item) would this this contribute to what you're getting?
 

·
Registered
Joined
·
6,098 Posts
Ive been discussing these on a couple of swedish forums. The main thing ive heard is that the ECU is self learning and supposedly can adjust itself if it detects any difference in waste gate pressures etc. But this doesnt sound like your problem, personally i would get onto forge as they make the thing and would be more likely to know. If not the greatest mind i know would be to get in contact with Stuart Sanderson at motorsport developments.
 

·
Registered
Joined
·
42 Posts
Discussion Starter · #7 ·
Thanks for all the pointers guys. I have spoken to pumaspeed & they have not had this problem before..

I have changed the map from DS to a Bluefin stage 3+ but still the same..

Seems to be all related to the boost.. I have let all of the preload off the actuator but still cuts, I have even put the stock actuator back on & the problem is still there!!! Which is really strange cause this wasn't the reason i change the actuator in the first place, i just wanted it to hold the boost a bit better..

It's going back on the dyno today so i will post up the graphs, but definatley an ECU fighting the boost..

I will Contact Stuart @ Motorsports Developments to see if he has any ideas..

Thanks Again for your help
 

·
Registered
Joined
·
42 Posts
Discussion Starter · #9 ·
QUOTE(troy45 @ 9 Dec 2009, 12:27 PM) <{POST_SNAPBACK}>
You're not running an aftermarket Dump Valve are you? could be worth checking out if you are.


No dump valve fitted i wish that was the problem.. Thanks
 

·
Registered
Joined
·
688 Posts
you,re not having much luck are you mate,i remember us talking about the actuator last time i was down.

if you need another car to experiment with or compare,give me a shout mate.


Den
 

·
Registered
Joined
·
42 Posts
Discussion Starter · #11 ·
QUOTE(denboy @ 9 Dec 2009, 08:53 PM) <{POST_SNAPBACK}>you,re not having much luck are you mate,i remember us talking about the actuator last time i was down.

if you need another car to experiment with or compare,give me a shout mate.


Den
Thanks Den. No it,s a problem no one seems to have had before!!! Just my luck at the moment..
It,s fine when i take the map back off & run back at 225bhp

Think it's time to put it stock & trade it in for a focus RS


If i do i will have some parts for sale mate, Are you up on Sunday for the MLR RR day???

I must take ya number
Cheers
 

·
Registered
Joined
·
1,358 Posts
I know how you feel mate, I've not bothered remapping my car again, too scared. And now i have another ESP warning now and then which is cutting the boost again It is
annoying. If i could afford to, i'd trade the car in even though i like it a lot.
 

·
Registered
Joined
·
688 Posts
QUOTE(Bobby B @ 10 Dec 2009, 08:27 AM) <{POST_SNAPBACK}>Thanks Den. No it,s a problem no one seems to have had before!!! Just my luck at the moment..
It,s fine when i take the map back off & run back at 225bhp

Think it's time to put it stock & trade it in for a focus RS


If i do i will have some parts for sale mate, Are you up on Sunday for the MLR RR day???

I must take ya number
Cheers

not the map itself,is it,you could always try the actuator on mine,just to see if it makes any difference,but i bet putting it on in the first place is a pig,just a thought
.

if you do trade in,i may be interested in some of your parts
.

pm-ing you my phone no. now.

take care mate.

Den.
 

·
Registered
Joined
·
688 Posts
QUOTEAre you up on Sunday for the MLR RR day???

got kent mlr xmas do on sat night and my company do on sunday,so doubt i,ll be there
mate.
 

·
Registered
Joined
·
2,345 Posts
bobby b, if have access or you are on the rsoc forum, have a word with someone called JOHN FRS. He might be able to help. he was instrumental in developing the forge/ direct combination on the mk1 focus rs.
 
1 - 15 of 15 Posts
Top