Ford Focus ST Forum banner
1 - 18 of 18 Posts

·
Registered
Joined
·
117 Posts
Discussion Starter · #1 ·
Hi, picked up my induction kit off Stevie G (legend by the way for making the sale happen), but Im not sure its working right. Took about 3 hours to fit because Im not great with a set of spanners. Anyway, it sounds pretty good, but it doesnt seem to make the pssssssst sound on let off every time. Ive checked everything is sealed correctly and in the right place. Any ideas? Also, I had a nightmare trying to get the ECU mounted as per the pics on the instructions and pics on here. So Im also a little worried its not getting the right amount of cooling. Is the positioning of it important for the cooling or is it just a recommended mount point? Any suggestions?

Cheers

kitch
 

·
FocusSTOC Nut!
Joined
·
17,448 Posts
is your car remapped mate. if not i guess the blow off,sound will be less noticable. ecu will be fine mate, no worries. others move it just for asthetics.
 

·
Registered
Joined
·
117 Posts
Discussion Starter · #3 ·
QUOTE(stingy @ 30 Jan 2010, 09:00 AM) <{POST_SNAPBACK}>is your car remapped mate. if not i guess the blow off,sound will be less noticable. ecu will be fine mate, no worries. others move it just for asthetics.


It is remapped mate. Running perf+ at the moment due to weather. I have a magnex catback too. It just seems a little hit and miss compared videos that people have posted previously.

Cheers.
 

·
FocusSTOC Nut&#33;
Joined
·
17,448 Posts
QUOTE(Kitch @ 30 Jan 2010, 09:02 AM) <{POST_SNAPBACK}>It is remapped mate. Running perf+ at the moment due to weather. I have a magnex catback too. It just seems a little hit and miss compared videos that people have posted previously.

Cheers.

mmmmm, strange. maybe try a different map. the noise is the internal dv. maybe not enough boost with perf+.
 

·
Registered
Joined
·
658 Posts
QUOTE(Kitch @ 30 Jan 2010, 09:02 AM) <{POST_SNAPBACK}>Running perf+ at the moment
There is your problem mate. you are not getting enough boost pressure with the softer map. Try swapping over to Race+ or DSCI and see the difference.
I always run mine on DSCI and get mega DV noise,But switched over to Performance+ last week (as im getting quite bad clutch slip with the harder maps) and now hardly get any DV noise at all

Steve
 

·
Registered
Joined
·
117 Posts
Discussion Starter · #7 ·
QUOTE(wolfman @ 30 Jan 2010, 09:40 AM) <{POST_SNAPBACK}>Hi James - The offer is still open for you to bring your car over and we can check your installation.


Thanks Gary - I think I might have to just so I am sure its right. I'll give you a ring next week because it will probably have to be late night Thurs again.

Stevie - I've just been out for a while with it on Dsci and you are right about the sound. Its much better.

However......... please tell me I am not describing clutch slip, but in 5th and 6th when I floor it, the revs build nicely then at about 3500k it just goes crazy and really over revs. Sometimes all the way to 7000k.



If it is clutch slip, how do I solve it?

Cheers.
 

·
Registered
Joined
·
658 Posts
QUOTE(Kitch @ 30 Jan 2010, 11:28 AM) <{POST_SNAPBACK}>Thanks Gary - I think I might have to just so I am sure its right. I'll give you a ring next week because it will probably have to be late night Thurs again.

Stevie - I've just been out for a while with it on Dsci and you are right about the sound. Its much better.

However......... please tell me I am not describing clutch slip, but in 5th and 6th when I floor it, the revs build nicely then at about 3500k it just goes crazy and really over revs. Sometimes all the way to 7000k.



If it is clutch slip, how do I solve it?

Cheers.
Welcome tyo the Clutch slip club dude,from what i've heard the standard clutch cannot cope with the extra torque that the stronger remaps put out,but is really pot luck with clutch slip.
Some cars get it,some cars have no issues.
I'm running mine on a smoother map for a few months until i can afford to have the RS clutch fitted.
 

·
Vendor
Joined
·
2,676 Posts
QUOTE(Kitch @ 30 Jan 2010, 11:28 AM) <{POST_SNAPBACK}>Thanks Gary - I think I might have to just so I am sure its right. I'll give you a ring next week because it will probably have to be late night Thurs again.

Stevie - I've just been out for a while with it on Dsci and you are right about the sound. Its much better.

However......... please tell me I am not describing clutch slip, but in 5th and 6th when I floor it, the revs build nicely then at about 3500k it just goes crazy and really over revs. Sometimes all the way to 7000k.



If it is clutch slip, how do I solve it?

Cheers.

It is certainly clutch slip - not fault of the tuning - just Ford have produced a batch of cars late 06 to late 07 which had a weaker clutch. All the 05-early 06 cars and the late 08> cars are fine with tuning on.

We can check that out if you come over
 

·
Registered
Joined
·
117 Posts
Discussion Starter · #11 ·
QUOTE(wolfman @ 30 Jan 2010, 03:02 PM) <{POST_SNAPBACK}>It is certainly clutch slip - not fault of the tuning - just Ford have produced a batch of cars late 06 to late 07 which had a weaker clutch. All the 05-early 06 cars and the late 08> cars are fine with tuning on.

We can check that out if you come over


Thanks Gary. I'll be over on Thursday then.

I assume I could buy a stronger clutch then from a later batch? A few people have mentioned an RS clutch, but there is no way I could afford that (would like intercooler etc first).

Nothing is ever simple, is it!
 

·
Registered
Joined
·
24,177 Posts
QUOTE(Kitch @ 30 Jan 2010, 03:23 PM) <{POST_SNAPBACK}>Thanks Gary. I'll be over on Thursday then.

I assume I could buy a stronger clutch then from a later batch? A few people have mentioned an RS clutch, but there is no way I could afford that (would like intercooler etc first).

Nothing is ever simple, is it!

I think youll find the RS clutch is either a similar price to the ST one or slightly cheaper! Its definitely worth the money though!
 

·
Registered
Joined
·
4,365 Posts
QUOTE(wolfman @ 30 Jan 2010, 03:02 PM) <{POST_SNAPBACK}>It is certainly clutch slip - not fault of the tuning - just Ford have produced a batch of cars late 06 to late 07 which had a weaker clutch. All the 05-early 06 cars and the late 08> cars are fine with tuning on.

We can check that out if you come over


Bit of a crystal ball moment, but as mine is a 56plate reg dec 12th 06, will this be in the batch of poor clutches.

Les
 

·
Registered
Joined
·
2,952 Posts
QUOTE(Les @ 30 Jan 2010, 03:54 PM) <{POST_SNAPBACK}>Bit of a crystal ball moment, but as mine is a 56plate reg dec 12th 06, will this be in the batch of poor clutches.

Les

by the sounds of it yes.
Mines an april 06 and no issues with any maps incl modc
 

·
Registered
Joined
·
1,152 Posts
I've got a 58 plate and it's been remapped from day one, also all the mods in my sig, not had any clutch slip issues at all (finds the nearest bit of wood to touch!)
 

·
Registered
Joined
·
117 Posts
Discussion Starter · #17 ·
Surely there is a way to solve it without spending a fortune. I've spent however much getting it to this stage and it looks like I can't use the top maps. To be honest, it even did it a little on perf+, so I don't have much option at all really.

Dreamscience, Wolfman...... there must be some tricks up your sleeves to fix it!!
 

·
Registered
Joined
·
117 Posts
Discussion Starter · #18 ·
Also, just one more thing.... does anyone have a picture of the tubes that need to go into the top induction pipe when fitted?

The one with the green clip thingy end doesn't seem to fit on either of the sections on the top pipe and one of them has a rubber blanking bit on it anyway.

Cheers.
 
1 - 18 of 18 Posts
Top