Ford Focus ST Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1,484 Posts
Discussion Starter · #1 ·
The radio display on my facelift SONY radio has now decided to not work but the radio still works. I can not see what station its on and it does not light up in any way. Has anyone had a similar issue and had it sorted out under warranty? I'm not holding my breath as the dealers cant diagnose worn inner CV joints
............................
 

·
Registered
Joined
·
286 Posts
Mine hasn't gone tottaly blank but sometimes only the CD numbers show (the 1 to 6) the ones at the bottom. Used to turn it on and off again until it the full display came back. I've just decided to get a new head unit off my mate he bought then decided he didnt want it to cure my problem
Might be worth taking it into ford, but they might just say you need a new stereo which would more than likely cost the amount for a new aftermarket stereo like a kenwood/pioneer lol!
 

·
Registered
Joined
·
242 Posts
Firstly, if your having trouble with the dealership identifying worn cv joints I would suggest you take it to another recognised dealer. You don't have to be loyal to where you bouight the car from! If more helpful dealership will more than likely attempt to solve the radio problem at the same timeif you mention it.
 

·
Registered
Joined
·
1,484 Posts
Discussion Starter · #4 ·
The radio started working in full again 2 days after it had a fit, i took the car to a different dealer out of town and its now ok (ish
) If it was a Vauxhall it would of been sorted out a long time ago in work
 

·
Registered
Joined
·
5 Posts
I had a similar problem. I would turn the radio on and it would have no lights but I could hear the radio. No buttons worked at all. I would have to turn the ignition off and on to get it to work and then it was random whether it worked or not. I took it to the dealers for a routine service and they asked if there were any other issues. I mentioned the radio and the seats. I had taken video of the radio not working properly on a few occasions as I expected the usual "We can't find any problem". When I picked the car up after the service the receptionist ran through what they had done in the service and said 'We've ordered you a new radio.' After I had come round from fainting I asked how they knew there was a problem. She told me the radio had logged the problem with the ECU (or whatever) and when they plugged the car in to their diagnostics, it had a fault code. New radio for me. Just wish I had asked to the firmware updated radio!
 
1 - 5 of 5 Posts
Top