Ford Focus ST Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter · #1 ·
hi there carnt believe it ive had the car 2 weeks and drove home to day and the light on the dash came on and it said esp system fault so i took it to the earest garage and it came back with 4 fault codes , P0420 catalyst system efficiency below threshold , P0480 fan1 control circuit , P0299 turbo/underboost and the last one P0101 mass or volume air flow circuitrange/performance problem???? the car seems to riun as normal ive just phoned the garage were i got it from and im taking it back t morra hopefully get this sorted the lad at the garage said its likely the maf sensor hope so !!!
 

·
Registered
Joined
·
4,604 Posts
Cat efficiency may be if the car has a sport cat or decat. Underboost can be a few things. Dud boost solenoid or actuator, loose manifold etc.
If it has a loose manifold the exhaust gasses escape out the side before they hit the turbo so you get errors with all the disagreements seen by sensors. Check the manifold nuts first. Mine came loose.

Fan issue, not sure. Is a fuse blown?
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #3 ·
just had the car out to pick the kids up from school and no warning lights on the dash all gone???? so dont no what to do now about taking it back to the garage ??
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #4 ·
following on just been out turned the car on no warning lights and the esp button works switching the esp on and off???? strange
 
1 - 5 of 5 Posts
Top