Ford Focus ST Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
59 Posts
Discussion Starter · #1 ·
Morning All, Happy Christmas,

I had some work done on the car the other day (CAIS, downpipe, Eibach's and Mongoose - car already had a CR software upgrade) but when I was driving down the motorway yesterday the engine warning light has come on. I think I have seen somewhere on here that this is normal and not to worry but I need to double check that this is not harming the car and how to reset it as the Mrs is not keen in driving it in this state!

Thanks

Wiggy
 

·
Registered
Joined
·
59 Posts
Discussion Starter · #3 ·
QUOTE(stevie g @ 26 Dec 2009, 11:15 AM) <{POST_SNAPBACK}>Have you changed the Cat?

Changed the turbo downpipe and back section. As far as I am aware (and I know I should know this...) cat stayed the same... All I know is there is a back section and big square boxy section sat in the hallway at home much to anoyance of the Mrs.
 

·
Registered
Joined
·
59 Posts
Discussion Starter · #4 ·
I just spoke to Gary at Profile and he states I should not have any warning lights on.. Looks like I will have to pop over and see him as he cant understand why they would be on.

Will keep people updated.
 

·
Registered
Joined
·
59 Posts
Discussion Starter · #5 ·
QUOTE(Wiggy @ 26 Dec 2009, 06:30 PM) <{POST_SNAPBACK}>I just spoke to Gary at Profile and he states I should not have any warning lights on.. Looks like I will have to pop over and see him as he cant understand why they would be on.

Will keep people updated.

Nipped over to Profile today - seems there was a "slow response" from the sensor on the downpipe. Quick clean and a rest from Gary seems to have done the trick. Cheers!

Wiggy
 
1 - 5 of 5 Posts
Top