Ford Focus ST Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
337 Posts
Discussion Starter · #1 ·
hello all
i have an 07 focust st2 with 23000 miles on it and now the engine management light has come on i have tried disconnecting the battery and leaving it for 20 minutes "while the alarm sounded" and the light went off but came back on after 30 miles i have had the car converted to run on gas and its running just the same on petrol or gas has ayone got any idia or are there any common faults ? any info welcomed before the man at ford gets me life savings cheers peter
 

·
Registered
Joined
·
1,158 Posts
Like already said it could be anything thats brought the MIL light on.

There are over 1100 fault codes that could bring the MIL light on.

Best thing to do is get the car read and that will give you a starting point to repairing it, i would hazrd a guess that its something to do with the gas conversion as i get a lot of gas converted vehicles in and 80% of them run with the MIL light on as the ECU doesnt like gas.
 

·
Registered
Joined
·
337 Posts
Discussion Starter · #11 ·
QUOTE(kosmo @ 2 Jan 2010, 08:28 PM) <{POST_SNAPBACK}>Gas?

Did you research that? ? ? I thought GAS and ST's had bad news written all over them?

Hopes you have a warranty.

it runs fine on gas as the motor has hardned valve seats there should be no problem went to a reputable gas installer to get the work done and it has its own warranty although it probably voided the ford warranty it has been worth dong "so far"
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top