Ford Focus ST Forum banner
1 - 20 of 25 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter · #1 ·
Hi Guys,

Seeking some sought after advice from newbie after ran into issue last night where the engine management light came briefly on. I have MK3 ST 2017, 13k miles.

I recently had stage 1 remap other day and it's been driving absolutely fine, drove 167 miles trip yesterday with no issues. I put super unleaded Tesco Momentum into it for first time on Friday with 50 miles still left on clock with normal 95 octane unleaded in.

However last night I accidentally from stationary revved hard from 1st gear whilst I believe inadvertently not fulling releasing the handbrake (although didn't seem to show handbrake was on) just ever so slightly on without and instantly I lose all power and got engine orange amber warning light flash with speed limiter staying stuck at 20mph. I pulled over and switched off the engine and switch it back on and light went off and hasn't come back on since.

My concern is now (albeit I could be just paranoid) but that I've done some undue damage as it feels like the car feels it's slightly lumpy/stuttering in low revs and when putting the power down, like it doesn't feel as quick to accelerate/boost in low range, again I could just be imagining this and could be absolutely fine. The car is fairly new. Any thoughts/ideas?. I've driven it today albeit mostly pedestrian but I feel like it feels bit lumpy and steering wheel is stiffer and there's slight delay in low range. The boost picks up then drops straight back down when releasing the gas which is expected.

Anything I should worry about, get checked out?

Thanks,

Rob
 

·
Administrator
Mk2 RS MP350
Joined
·
24,589 Posts
You've probably still got a fault code stored if one arose so best to get a code reader on it and find out what it says.
Could it be you lost traction so just had traction control kicking in?
 

·
Registered
Joined
·
12 Posts
I'm no techie but my advice if you get an engine management light come on is to get it checked out.

I've got a 66 plate ST diesel and have had a number of issues with sensors over the last year. Luckily I took an extended warranty when I brought it in 2017 which kicked in when the Ford warranty finished and all three sensors I've had changed were done under warranty.

The first was a sensor to do with the Cat. The engine management light came on but went off when I stalled the car a few days later. The dealer could only find the fault when the light came back on about a month later.

I then had the engine management light come on this June which was diagnosed as a sensor that controlled the DPF. They replaced the sensor but told me my DPF wouldn't regenerate and wanted £1500 to replace it.
I got a mobile company to clean the DPF on my drive and they found another sensor fault on the exhaust temperature system when they ran their diagnostics. This had never registered on the car but the dealer did find it when they put their diagnostics on and this was also replaced under warranty.

The extended warranty runs out in Sept 2022 hence I've got a Mk4 on order - if I ever see it!
 

·
Premium Member
Jason SB MK3 RS MAXD 400
Joined
·
3,078 Posts
I’m inclined to to think like Alb said it was the traction control kicking in as planting it in 1st gear is likely to cause this.
 

·
Premium Member
Nick - Mk3.5 FL ST3 Moondust Silver
Joined
·
5,699 Posts
The light hasn't returned and I seem to still get power/boost, I just don't know if it feels same as after the stage 1 remap I had four days ago but been driving fine until this incident last night. Would this OBD scanner be sufficient? Streetwize OBDII Fault Code Reader | Euro Car Parts
I got one of these after being recommended by Alb I think & it has been faultless. Easy to use & does what it says on the tin!

New Universal Car Fault Code Reader D900 OBD2 EOBD CAN Diagnostic Scanner Tool | eBay

As above you likely had the TC kick in but if it was a fault code it can be sitting in the system causing an issue. Best thing is to check & clear anything to be sure.
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #7 ·
Engine light still hasn't come back on in two days and been driving it around Cornwall and seems okay. I've bought the reader I've linked above. Will try it out tomorrow. I hope my stage one 1 remap that I had done last Wednesday won't be affected? When you said I lost traction, traction control is on by default, why would the TC kick in to thrown a solid engine amber light when flooring it in first gear from standstill and cause engine error and all power to suddenly halt and the speedometer to stay stuck at 20mph? Could it be the remap? Could be that I've killed a sensor by flooring it from first and not realising I still had handbrake on just ever slightly? Sorry for all questions, just overly concerned that I've lost the same driveability/torque and acceleration since the stage one 1 remap last week? As it felt amazing after the remap last week. It seems to not pull as quick in low gears. Then again could just be me imagining it since I had the solid information orange light come on briefly before turning engine off and back on again it hasn't returned. I will plug in reader tomorrow and see what it says.
 

·
Administrator
Mk2 RS MP350
Joined
·
24,589 Posts
I doubt you've broken anything and the handbrake issue is a red herring IMHO.
You may or may not have triggered some level of reduced performance but you can't be sure until you have read and assessed the codes.
Time will tell .......
 

·
Premium Member
Graham - mk2 stage 3
Joined
·
5,228 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter · #10 ·
Okay, so I can report that having just plugged in using Streetwize OBDII Fault Code Reader, no codes have come up.


Does it mean that incident in all likelihood of flooring it in 1st gear with TC on and handbrake slightly on, was just the engine going into "limp mode" temporarily (until ignition was restarted) as a measure to protect? Would someone who has better understanding than me mine explaining what limp mode is and why this occured? Just because there was no codes detected, would this still be indicative of an issue with power in higher revs/higher gears and my stage one remap that I had done last week? Could I have a boost leak? I mean the light hasn't returned, we've been driving for 150miles or so since with no issues, the turbo gets up to 3/4 on the boost gauge and even into red on boost gauge when I had a chance to revved it from 3rd gear up hill on dual carriageway.


Thanks,

Rob
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #13 ·
Can you revert to your standard map for a comparison?
I'd have to take it back to the specialist garage who did remap to compare or get them to put it on the Dyno. Tbh I might just do that next week when I'm back off holiday as they said any problems to come back. So I'll have to get them to test it I guess and report the brief issue I had. I'll just tell them engine warning light came on and I lost power.
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #14 ·
Mine is remapped and I have never seen the boost guage in the red
I haven't either, normally goes no more than 3/4, it was only briefly hit the end when accelerating fr third gear then immediately dropped back down. So dunno if that means anything or that's indicative of a problem...I mean no codes so I don't know.
 

·
Premium Member
Joined
·
4,120 Posts
One thing I wouldnt do is don't put that S#\%# stuff Tesco in as that won't help in my opinion...But as mentioned above yes it sounds like the traction control had kicked in
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #16 ·
One thing I wouldnt do is don't put that S#\%# stuff Tesco in as that won't help in my opinion...But as mentioned above yes it sounds like the traction control had kicked in
Haha, what's wrong with momentum 99? What stuff would you put in?
 

·
Premium Member
Joined
·
4,120 Posts
I don't want to get on the "What's best Fuel "topic as the Fuel paramedics will come out lol
But I use Shell V Power only because I just believe in Good Quality ...and I'm not one that's fussed about How much it costs per litre lol
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #18 ·
Haha I had inclination you might suggest that. I'm going fill up with couple of full tanks of Shell V power anyway just to see if I can feel the difference in driveability and smoothness.
 

·
Premium Member
Jason SB MK3 RS MAXD 400
Joined
·
3,078 Posts
All comes down to personal opinion whatever you do with a car be it fuel, crossover pipes, open cone filters, off the shelf maps, custom maps :rolleyes:
 
1 - 20 of 25 Posts
Top