Ford Focus ST Forum banner
1 - 20 of 30 Posts

·
Registered
Joined
·
389 Posts
Hey Guys..

After sorting out a boost leak end of last year i now worry (possibly a bit OTT now lol) about any hissing noises.. I had to replace 2 hoses that had got a bit damaged, Wont go into detail as the damage was self inflicted


Anyway, I fitted a new DS induction kit, New Pro-Alloy charge pipe and relocated the ECU into the new Focus RS ECU box..

I have read most of your threads about the DS induction kit and can honestly say that it meets all expectations as far as the noise is concerned and of course the performance gains


So.. After a nice drive back home from my work i noticed quite a bit of hissing, the same kind of hissing that i was getting before except that the car was holding 1.2 bar of which it didnt before!!(.8 bar if i was lucky) I dont think that its the actual Induction kit as i cant see much going wrong with that, Im quite sure that i have tightened all the boost hose clips up enough, Although im going to run around all the clips again and give them all a small tighten (not too much)

The Pro-Alloy Pipe gave me a small bit of Jip in fitting it, The small pipe that leads to the recirculating Valve was a slightly smaller diameter than the original so i had to fit a new jubilee clip instead of the clip attached to the original ''L'' shaped rubber pipe.. And got a good seal on it, All appeared to be good.
So basically i was expecting the pronounced spooling up noise of the turbo, The ''sucking/Hissing'' noises too and of couse that enhanced Chatter


Could it be that im just looking for trouble from my past problems with boost leaks?? and that the DS kit does
have some excessive hissing noises apon inducting the air.. Im quite happy with the sound if its not a leak LOL.

Even better would be for me to meet up with someone in the SE London/NW kent area that has the DS Induction kit either to take them out in it or be taken out!!

Whats your thoughts?? Thanks in advance for your help..

Cheers - Phil
 

·
Registered
Joined
·
699 Posts
QUOTE(philbotley @ 17 Jan 2010, 10:01 PM) <{POST_SNAPBACK}>Hey Guys..

After sorting out a boost leak end of last year i now worry (possibly a bit OTT now lol) about any hissing noises.. I had to replace 2 hoses that had got a bit damaged, Wont go into detail as the damage was self inflicted


Anyway, I fitted a new DS induction kit, New Pro-Alloy charge pipe and relocated the ECU into the new Focus RS ECU box..

I have read most of your threads about the DS induction kit and can honestly say that it meets all expectations as far as the noise is concerned and of course the performance gains


So.. After a nice drive back home from my work i noticed quite a bit of hissing, the same kind of hissing that i was getting before except that the car was holding 1.2 bar of which it didnt before!!(.8 bar if i was lucky) I dont think that its the actual Induction kit as i cant see much going wrong with that, Im quite sure that i have tightened all the boost hose clips up enough, Although im going to run around all the clips again and give them all a small tighten (not too much)

The Pro-Alloy Pipe gave me a small bit of Jip in fitting it, The small pipe that leads to the recirculating Valve was a slightly smaller diameter than the original so i had to fit a new jubilee clip instead of the clip attached to the original ''L'' shaped rubber pipe.. And got a good seal on it, All appeared to be good.
So basically i was expecting the pronounced spooling up noise of the turbo, The ''sucking/Hissing'' noises too and of couse that enhanced Chatter


Could it be that im just looking for trouble from my past problems with boost leaks?? and that the DS kit does
have some excessive hissing noises apon inducting the air.. Im quite happy with the sound if its not a leak LOL.

Even better would be for me to meet up with someone in the SE London/NW kent area that has the DS Induction kit either to take them out in it or be taken out!!

Whats your thoughts?? Thanks in advance for your help..

Cheers - Phil

if the boost is holding im sure its fine ,i thinks it would be the turbo spooling up as you will hear it alot better now
 

·
Registered
Joined
·
389 Posts
Discussion Starter · #3 ·
QUOTE(shug1986 @ 17 Jan 2010, 10:05 PM) <{POST_SNAPBACK}>if the boost is holding im sure its fine ,i thinks it would be the turbo spooling up as you will hear it alot better now


Yeah thats the bit that makes me think its just me reading too much into the noises.. I also get the odd bit of whistling on idle or when im coasting with my foot off the throttle?

Another factor i forgot to mention is that i removed both the air scoops either side of the intercooler too so i guess im getting all kinds of additional intake noises lol

Thanks - Phil
 

·
Registered
Joined
·
699 Posts
QUOTE(philbotley @ 17 Jan 2010, 10:29 PM) <{POST_SNAPBACK}>Yeah thats the bit that makes me think its just me reading too much into the noises.. I also get the odd bit of whistling on idle or when im coasting with my foot off the throttle?

Another factor i forgot to mention is that i removed both the air scoops either side of the intercooler too so i guess im getting all kinds of additional intake noises lol

Thanks - Phil

yeah i would think so mate i have taken those out as well
 

·
Registered
Joined
·
389 Posts
Discussion Starter · #6 ·
Thanks for thoughts Guys..

Perhaps im just over reacting about it all, Only fitted it yesterday lol so not really given it a chance


I probably will give all the fixings a once over as that wont hurt.. Im currently modifying a RS top slam panel cover to fit as it has the 2 air intake bulges, OS one will feed air to the ecu box and for the NS I will make up an additional cold air feed intake to run down to the K&N filter room permitting lol.. As the intake for the RS comes only with the RS airbox


Cheers - Phil
 

·
Registered
Joined
·
389 Posts
Discussion Starter · #7 ·
Ok so i managed to get the car into work during my lunchtime..

Nipped up all the jubilee clips etc and found most of them to be loose lol, Either i didnt do them up sufficiently or its a simple case of letting it settle in and re-tighten as you would after removing/refitting your wheels!!!

Anyway all good now, Still get a bit of hissing but im putting that down to the characteristics of the DS induction


Quick Q regarding the DS kit.. Mine whistles even on idle, Im assuming that this is normal and just the Filter doing its job.. ??

Other than that im loving it to bits


Phil
 

·
Registered
Joined
·
2,694 Posts
Hi I just got the d/s cais fitted last week, I don't have any whistle at idle,
when driving the car and you are giving the throttle the lightest of pressure
you get the whistling, but no throttle or full throttle=no whistling!

When you give it full throttle it would suck the dust out of an axminster at 30 yards
.

Happy days
.
 

·
Registered
Joined
·
389 Posts
Discussion Starter · #9 ·
QUOTE(jim g @ 18 Jan 2010, 08:24 PM) <{POST_SNAPBACK}>Hi I just got the d/s cais fitted last week, I don't have any whistle at idle,
when driving the car and you are giving the throttle the lightest of pressure
you get the whistling, but no throttle or full throttle=no whistling!

When you give it full throttle it would suck the dust out of an axminster at 30 yards
.

Happy days
.

Cheers Jim.. Yeah the whistling is really quiet on idle/coasting, gets more pronounced when you press a bit more then it does dissapear and turns into a jet fighter when you floor it..


I'm staring to think that i may have a totally unrelated issue, getting some quite loud grating/grinding when i reverse off my driveway and on occasion im getting some light rumbling, Could possibly be the start of a worn wheel bearing??!!

Thanks - Phil
 

·
Registered
Joined
·
389 Posts
Discussion Starter · #11 ·
QUOTE(jim g @ 18 Jan 2010, 08:39 PM) <{POST_SNAPBACK}>It could be Phil,might be a stupid question but are your wheels tight?Are your front brake pads worn?
Might be worth checking the simple things first,let us know how you get on?

Yeah the brakes are about 2/3rds worn was gonna replace them in the next service in a month or so
Will double check the wheel nuts tomorow just incase..

Also im getting loads more noises of course from where the scoops have been removed!!

Will advise of my findings


Cheers - Phil
 

·
Registered
Joined
·
279 Posts
I get tons of whistling from my ds and I've nipped everything up, mum drove the car the other day and I could hear it whistle from in the houseoh and the " scoops" they refer to is air deflectors that guide air onto the core of the intercooler instead of going around the intercooler
 

·
Registered
Joined
·
389 Posts
Discussion Starter · #14 ·
QUOTE(Damo1 @ 19 Jan 2010, 11:50 AM) <{POST_SNAPBACK}>I get tons of whistling from my ds and I've nipped everything up, mum drove the car the other day and I could hear it whistle from in the houseoh and the " scoops" they refer to is air deflectors that guide air onto the core of the intercooler instead of going around the intercooler

Hi Mate..

Do you get whistling on idle with yours???

Cheers - Phil
 

·
Registered
Joined
·
360 Posts
QUOTE(philbotley @ 19 Jan 2010, 01:18 PM) <{POST_SNAPBACK}>Hi Mate..

Do you get whistling on idle with yours???

Cheers - Phil


I get whistling on mine which im not convinced is normal, had it for a long time now on startup idle and part throttle, even gentle lift off and after dump valve does its thing. DS say its fine and it holds its boost.

Gonna strip it and refit in warmer weather, maybe with RS ecu box. How did you find the ecu box to fit?

As for your rumbling / grinding noise, have a quick check of your DS top pipe and make sure its clear of the strut brace at the back. The gaps move quite a lot as it gets warm/cold.

Andy
 

·
Registered
Joined
·
389 Posts
QUOTE(AC555 @ 19 Jan 2010, 02:17 PM) <{POST_SNAPBACK}>I get whistling on mine which im not convinced is normal, had it for a long time now on startup idle and part throttle, even gentle lift off and after dump valve does its thing. DS say its fine and it holds its boost.

Gonna strip it and refit in warmer weather, maybe with RS ecu box. How did you find the ecu box to fit?

As for your rumbling / grinding noise, have a quick check of your DS top pipe and make sure its clear of the strut brace at the back. The gaps move quite a lot as it gets warm/cold.

Andy

Well if DS say its normal then im not gonna worry about it anymore lol..

Yeah the RS ecu covers are a doddle Mate.. Just need to remove the Radiator hose from the rad on the ns and re-route the wiring harness above the hose instead of underneath it.. its a great mod and looks ace..

I did put a small bit of foam on top of the DS pipe but i dint think it is sufficient so will probably change it for something a little more substantial..

Cheers - Phil
 

·
Registered
Joined
·
389 Posts
OMG!!!!


So it turns out that i had probably over tightened the bracket that supports the DS filter pipe to the chassis leg, Im assuming that the fact it has a rubber bush on it means that it is meant to move and allow flex for engine movement
not for tightening so it cant move no more!!

I went to my car lunchtime today to fit a better bit of foam to the strut brace for cushioning the top DS pipe when i found the 1st samco hose had pulled off the MAF sensor housing and the jubilee clip was in half balancing on one of the wiring harnesses


Thanks to Dreamscience who have bunged a new jubilee clip in the post for me lol, Cheers Guys!!

So when that arrives im gonna loosen off the bracket bold to the chassis leg which i have finally realised must allow flex for the pipes to move with the engine..

So back to the drawing board again.. Was all going well too


Sorry to bore you all - Phil
 

·
Registered
Joined
·
389 Posts
Discussion Starter · #19 ·
QUOTE(gizm0 @ 20 Jan 2010, 09:17 PM) <{POST_SNAPBACK}>what are the scoops you have removed? what difference does it make? any pics by anychance? cheers

The scoops/blanks that sit either side of the intercooler that follow the shape of the centre bumper grille..



I'm not going to say they help or hinder in being there or not, You could argue that they are flush with the intercooler instead of sloping in at an angle to create a smooth flow of air into the intercooler.. Also yes you do end up with air going around the intercooler as well as going through it but either way the air is gonna go through it!!

I modified mine to fit the Airtek but are now removed to air in cooling my Alloy charge pipe and to help with feeding cold air to the K&N cone till i can fabricate some cold air feeds..

Phil
 

·
Registered
Joined
·
2,694 Posts
QUOTE(philbotley @ 20 Jan 2010, 09:03 PM) <{POST_SNAPBACK}>OMG!!!!


So it turns out that i had probably over tightened the bracket that supports the DS filter pipe to the chassis leg, Im assuming that the fact it has a rubber bush on it means that it is meant to move and allow flex for engine movement
not for tightening so it cant move no more!!

I went to my car lunchtime today to fit a better bit of foam to the strut brace for cushioning the top DS pipe when i found the 1st samco hose had pulled off the MAF sensor housing and the jubilee clip was in half balancing on one of the wiring harnesses


Thanks to Dreamscience to have bunged a new jubilee clip in the post for me lol, Cheers Guys!!

So when that arrives im gonna loosen off the bracket bold to the chassis leg which i have finally realised must allow flex for the pipes to move with the engine..

So back to the drawing board again.. Was all going well too


Sorry to bore you all - Phil

That'll have been your problem then Phil? I have plenty of room between the d/s top pipe and the strut brace, I start my work tomorrow and I won,t be home till friday night,when I come home I,ll take a pic of mine for reference,glad your getting it fixed though
.
 
1 - 20 of 30 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top