Ford Focus ST Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
531 Posts
Discussion Starter · #1 ·
Got caught out by a large puddle on the way home from work. Now when the car comes on boost theres a sudden and dramatic loss in power causing the car to nose dive, it also felt grumbly and sluggish at times since
When i got home and stopped it seemed ok and revs freely when stopped and now ticks over normally. Ive got a k&n gen2 fitted.

Is it possible I've sucked up some water and knackered my maf? Or something worse?
 

·
Registered
Joined
·
10,661 Posts
Got caught out by a large puddle on the way home from work. Now when the car comes on boost theres a sudden and dramatic loss in power causing the car to nose dive, it also felt grumbly and sluggish at times since
When i got home and stopped it seemed ok and revs freely when stopped and now ticks over normally. Ive got a k&n gen2 fitted.

Is it possible I've sucked up some water and knackered my maf? Or something worse?
It could have ingressed moisture to the MAF, but if it is now running ok after restarting the car it may be ok. The initial moisture may have induced limp mode but after drying out and clearing the fault by restarting you may be ok if it now runs ok.
 

·
Registered
Joined
·
310 Posts
i hit a massive puddle last month, i had no running issues but lost my splitter and both undertrays! ill second what the rest have said!
 

·
Registered
Joined
·
5,303 Posts
It could also be the ESP/ traction control kicking in too early as you are only getting the problem when you boot it, that cuts the power and generally makes the car feel dead.... Hopefully will be all OK when dried out.
 
1 - 7 of 7 Posts
Top