Ford Focus ST Forum banner
1 - 20 of 24 Posts

·
Registered
Joined
·
110 Posts
Well after just over a week or so having splashed out £250 to repair a broken clutch pedal spring, my clutch pedal is now making a right racket.

Very annoying unless I've got music on loud or I'm doing 70mph.

Any thoughts on what it could be? It sounds metallic to me - I don't think it's the springs or the clutch switch but you never know. I just can't seem to figure out what point it clicks, I'm just hoping it's an easy fix.

Any opinions would be welcome. Video below

https://flic.kr/p/dz7DwN
 

·
Registered
Joined
·
110 Posts
Discussion Starter · #3 ·
I don't think anything is broken though, pedal feels fine etc and I can't feel no looseness.

So annoying...
 

·
Registered
Joined
·
110 Posts
Having spoken with someone via PM they had the same issue which was cured by a new master cylinder, he said his was weeping slightly.

I have just checked mine and I think mine may be the same, it's definately leaked fluid at some point but I don't know if that'll have been from when it was removed to change the spring or since then.

Eitherway I'm not too happy as you can understand, only had the car 20 days and the clutch pedal is giving me real frustration and is hurting my wallet.

Would anyone like to go check their master cylinder, with a bit of luck we could rule it out...
 

·
Registered
Joined
·
110 Posts
Discussion Starter · #10 ·
Thanks for the input, and you could be right. I'm going to dry off my cylinder to rule it out.

Modulating the pedal slowly by hand, it *could* be the yellow plastic spring.

Who knows
 

·
Registered
Joined
·
110 Posts
Discussion Starter · #12 ·
How many miles have you done in the car?

Mine came with a broken spring so the pedal sat half an inch below where it should, I then had the spring replaced and only 600 miles later it could be knackered! That's £2.43 a mile for every spring repair...

Anyway I have cleaned up the master cylinder so any leaks will be obvious, and further investigation gives me the hump that it could be the yellow spring. I think it clicks just as the piston begins to move, and it's silent if you move it very slowly.

I noticed from new they are shipped in sealed bags from Ford, covered in grease, only there's no way this noise will be suppressed with lubricant.
 

Attachments

·
Registered
Joined
·
1,753 Posts
mines done 44k now, I also looked at that spring and like you say pressing it slowly doesnt make it click however I also greased it again and that made no difference

how much was the spring?
 

·
Registered
Joined
·
12,607 Posts
I have a slight click, but noticed the same thing on a couple of fiestas I've driven too so nothing to worry about in my case
 

·
Registered
Joined
·
23 Posts
Hi Guys

Did anyone ever get to the bottom of the clicking clutch pedal...? Mine also does this, doesnt cause any issues and half the time I dont notice it. But can be a little annoying when you do. Was there a quick fix ?
 

·
Registered
Joined
·
252 Posts
Hi Guys

Did anyone ever get to the bottom of the clicking clutch pedal...? Mine also does this, doesnt cause any issues and half the time I dont notice it. But can be a little annoying when you do. Was there a quick fix ?
Hiya Mike

Mine started making this noise a week or so after having the RS clutch fitted.... Beginning of this week i noticed the pedal at times not returning back to normal position.... and then Wednesday got in the car after popping into a shop and found the yellow spring thingy from the picture in this thread in my footwell.... Having spoked to Phil at pumabuild he said its the clutch pedal spring kit and takes roughly 1-2 hrs to fit...... Im heading off to frauds today to get one and have a go at fitting..... I'll let you know how i get on ...... Hope this helps

Steven
 

·
Registered
Joined
·
23 Posts
Hiya Mike

Mine started making this noise a week or so after having the RS clutch fitted.... Beginning of this week i noticed the pedal at times not returning back to normal position.... and then Wednesday got in the car after popping into a shop and found the yellow spring thingy from the picture in this thread in my footwell.... Having spoked to Phil at pumabuild he said its the clutch pedal spring kit and takes roughly 1-2 hrs to fit...... Im heading off to frauds today to get one and have a go at fitting..... I'll let you know how i get on ...... Hope this helps

Steven
Hi Steven

How did you get on ??
 

·
Registered
Joined
·
4,365 Posts
Hiya Mike

Mine started making this noise a week or so after having the RS clutch fitted.... Beginning of this week i noticed the pedal at times not returning back to normal position.... and then Wednesday got in the car after popping into a shop and found the yellow spring thingy from the picture in this thread in my footwell.... Having spoked to Phil at pumabuild he said its the clutch pedal spring kit and takes roughly 1-2 hrs to fit...... Im heading off to frauds today to get one and have a go at fitting..... I'll let you know how i get on ...... Hope this helps

Steven
good luck I think the pedal box has to come out, I tried to do mine when it broke.

Les
 
1 - 20 of 24 Posts
Top