Ford Focus ST Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
211 Posts
Hi

Just wondering if anyone could help me who lives near Wokingham/Bracknell if you could possibly take me out for a drive (me as passenger) in your ST, I have a Mountuned ST with other mods inc RS Clutch/Flywheel but every now and then the car feels a bit hesitant like the clutch is still slightly slipping. With the RS upgrade I very much doubt that it is and is probably a bit of turbo lag etc but would like to compare it to another ST.

For example if I am going along in say 4th gear at 40mph then put my foot down the engine note seems to pick up a bit to much before the speed increases, maybe it's just because of the Symposer pipe bringing more noise into the cabin but to me the pick up seems slightly delayed.

Does anyone else think this about the ST?

Also the clutch pedal seems to feel spongy at the top, when I went to profile Gary did mention that in other ST's the pedal springs right back up to the top whereas mine you can put your foot under the pedal and lift it up another cm or so (almost like a return spring is missing), he did say maybe could be Master cylinder is slightly fault. I understand it that the hydraulics just release the clutch and it's just mechanical pressure plate keeping it engaged so wouldn't have thought even if I had some fault it would make it slip.

Sorry to bore you but can anyone shed some light on this?

Cheers

Rob
 

·
Registered
Joined
·
124 Posts
QUOTE(rob2477 @ 16 Dec 2009, 11:23 PM) <{POST_SNAPBACK}>Hi

Just wondering if anyone could help me who lives near Wokingham/Bracknell if you could possibly take me out for a drive (me as passenger) in your ST, I have a Mountuned ST with other mods inc RS Clutch/Flywheel but every now and then the car feels a bit hesitant like the clutch is still slightly slipping. With the RS upgrade I very much doubt that it is and is probably a bit of turbo lag etc but would like to compare it to another ST.

For example if I am going along in say 4th gear at 40mph then put my foot down the engine note seems to pick up a bit to much before the speed increases, maybe it's just because of the Symposer pipe bringing more noise into the cabin but to me the pick up seems slightly delayed.

Does anyone else think this about the ST?

Also the clutch pedal seems to feel spongy at the top, when I went to profile Gary did mention that in other ST's the pedal springs right back up to the top whereas mine you can put your foot under the pedal and lift it up another cm or so (almost like a return spring is missing), he did say maybe could be Master cylinder is slightly fault. I understand it that the hydraulics just release the clutch and it's just mechanical pressure plate keeping it engaged so wouldn't have thought even if I had some fault it would make it slip.

Sorry to bore you but can anyone shed some light on this?

Cheers

Rob
Hey Rob.

I'm afraid i don't live any where near but i may be able to help. I have Mountune with just a standard ST clutch and it doesn't hesitate at all that i can notice, and i only get nano seconds of turbo lag, and that's only when i'm at low revs in a high gear. So i would say there may be something going on with your car mate, probably the best thing would be to go to your local garage and get them to have a proper route around and see what they can find. But it sounds like the Mountune remap may not be quite right, that would cause hesitation. As would fuel not getting through properly.

Hope i've helped in some way mate.
Good luck.

Darren
 

·
Registered
Joined
·
16 Posts
QUOTE(rob2477 @ 16 Dec 2009, 11:23 PM) <{POST_SNAPBACK}>Hi

Just wondering if anyone could help me who lives near Wokingham/Bracknell if you could possibly take me out for a drive (me as passenger) in your ST, I have a Mountuned ST with other mods inc RS Clutch/Flywheel but every now and then the car feels a bit hesitant like the clutch is still slightly slipping. With the RS upgrade I very much doubt that it is and is probably a bit of turbo lag etc but would like to compare it to another ST.

For example if I am going along in say 4th gear at 40mph then put my foot down the engine note seems to pick up a bit to much before the speed increases, maybe it's just because of the Symposer pipe bringing more noise into the cabin but to me the pick up seems slightly delayed.

Does anyone else think this about the ST?

Also the clutch pedal seems to feel spongy at the top, when I went to profile Gary did mention that in other ST's the pedal springs right back up to the top whereas mine you can put your foot under the pedal and lift it up another cm or so (almost like a return spring is missing), he did say maybe could be Master cylinder is slightly fault. I understand it that the hydraulics just release the clutch and it's just mechanical pressure plate keeping it engaged so wouldn't have thought even if I had some fault it would make it slip.

Sorry to bore you but can anyone shed some light on this?

Cheers

Rob

I live Bracknell and happy to help if still want a test drive:].
 

·
Registered
Joined
·
211 Posts
Discussion Starter · #5 ·
Cheers for this mate, I am still interested in a test drive.

Whenever's convenient with you really, I am in the lovely Home Farm/Great Hollands area.

Let me know and I will either drive round to your's or meet somewhere, whatevers best for you.

Cheers

Rob
 

·
Registered
Joined
·
16 Posts
QUOTE(rob2477 @ 4 Jan 2010, 08:51 PM) <{POST_SNAPBACK}>Cheers for this mate, I am still interested in a test drive.

Whenever's convenient with you really, I am in the lovely Home Farm/Great Hollands area.

Let me know and I will either drive round to your's or meet somewhere, whatevers best for you.

Cheers

Rob

We could meet during the weekend, Im pretty much free till 4pm on every Saturday so if thats convenient for you give me a call on 07514929073. Iam Ogden park area and happy to drive to your place if you wish.

Matt
 
1 - 6 of 6 Posts
Top